Author Topic: Bug list from my short experience  (Read 100 times)

Blackwood

  • Wanderer
  • *
  • Offline Offline
  • Posts: 2
    • View Profile
Bug list from my short experience
« on: May 12, 2019, 09:16:00 PM »

Hi there, that´s my first post in the forum and I first wanted to congratulate the devs for this awesome game with those combat mechanics. There it goes few bugs I´ve seen (and some strange behaviours I´m sure that are bugs too) to contribute to this test season. First I´ll note that when I load the game, on the login screen, I find this message and I´ve still not figured out the reason (maybe it´s causing some of the bugs I'll report):

ERROR: Unable to load: /cirn_stuff/foodan/2headed fishv2.png. (I won´t see an ugly mutant fish?)
ERROR: Unable to load: . (Current directory can´t be loaded?)

1. Alt+Click to drop items one by one in room (I´ve to note that I am in a sewer room) does not substract the weight of the item, while it drops in the ground. If I am carrying 100Kg in items, and I drop all them in the ground using Alt+click, the weight I am carrying stays the same.

2. The Field of View using Crtl+F does not work properly on the upper left corners of some maps: I´ve found this bug in the police department (no matter the zoom or the position of my character, only my camera moving throught this area) and in other few northern zones I don´t remember. The things my character can actually see are correctly shown (or hidden) depending on where I am looking, but the "fog of war" (the darkened tone of the hexes where my character perception does not reach) is not shown. FoV displayed with "q" is correctly shown.

3. I can't reproduce this bug again, but it just happens after few hours of game and I have to shut down the game and execute it again in order to correct it: All corpses are highlighted when switching to attack mode, no matter if the critters / players have negative hit points, they are completely well or beyond any help.

4. Some critter spawns behave like plants when you pass throught them: they don´t move or attack unless you hit them. You can actually hug a matriarch deathclaw without any consequence. Sometimes only one of the critters react to your presence, but not always. They act correctly (with their habitual bloodthirst I mean) when you attack any of them.

5. "Miniquest" of the psycopath ghoul (the one in the south tent in the sewers) does not work properly, or it´s lacking of a correct explanation: it asks to kill ten living things (I am not sure if animals, players or both) and report back to him. I´ve killed tones of things since I agreed to do it, but it still displays the same message with the same answers.

6. Persuasion skill does not grow up after lots of barter inteactions with the dwarf shop in the sewer. I am not sure if bartering is the only way to increase it, but it just does not move (maybe it´s just the sewer shop that does not work).

7. If you have your IU hidden throght F4 while crossing a map and you press F4 again in order to show the IU again, if the map is not loaded yet while you do it, the numbers (hit points, weapon screen, rads, action points) are displayed separatedly from the rest of the interface, so when you press F4 further times it shows either the interface or the numbers, but not both at the same time. Repeating the process or restarting game solves the issue.

8. I´ve already registered 2 characters, but I can't do it with a 3rd one. I´ve tried to create a character called "sample12" with password "sample12". No error message and yet I can´t connect: Incorrect login or password.

9. I already responded on another thread about this: Centaurs and floaters dissapear after a message saying "you harvest the body", but nothing appears on the inventory. Well, I guess they shouldn't give you anything anyway. Centaur and floater meat is probably more toxic than a PvP forum.

10. I am not sure if it´s a bug, but I hate the programmer who designed the sewer holes to go back to the neutral or factionless base: I was literally one hour seeking for an entrance arround Maryland, Warmart, Paradise and Hospital sewers trying to survive grey deathclaw spawns with all my HQ materials on the inventory while none of them were appearing. Should't be at least one fixed entrance? I guess the dinamic appeareance of the sewer tunnels makes life in the sewers much harder and funny... but it´s obnoxious when you just want to leave the game and your character is full of well earned loot. 

Well, that´s all. Game is fucking awesome anyway and I am having tons of fun while I am being shot and looted by all factions... except Lawers. Those fascists loved me and will earn a new member soon.
Logged
 



SMF 2.0.2 | SMF © 2011, Simple Machines
Simple Audio Video Embedder - Theme by Crip